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Three elements of effec tive web design

Content: what is on the site?

Content is the most important part of any web site.  The purpose of most websites is to deliver information.  It 
stands to reason then that the most important aspect of a site would be the information it presents.  Make sure 
that your content supports the purpose of your site, that it is appropriate for the audience(s) you are targeting, 
and that it is well written, concise, accurate and current.

Functionality: how does the site work?

Functionality of the site includes things such as navigation, structure and clarity.  Are the navigation elements 
clearly labeled and easy to find?  Does the structure of the site make sense?  Can people easily find what they’re 
looking for?

Design: how does the site look?

Contrary to what many people might think, design should be one of the last considerations when planning a 
website.  Good design is important. You obviously want your site to look nice and good design will engage your 
viewers and can be used to enhance both content and functionality. However, design should never take prece-
dence over content or functionality.  

Planning your content

Define the site’s purpose

The first step in defining what your content will be, is deciding what the purpose of your site will be.  Will you 
use your site as an informational tool (contact information, syllabus, office hours) that will be updated once or 
twice a semester ?  Will your site be a teaching tool (including pictures, links to articles, links to an iLearn class) 
and need to be updated frequently?  Or will it be somewhere in between?  What other goals would you like to 
achieve with your website?

Once you’ve come up with a fairly clear decision on what exactly it is you want to do with your site, you will sim-
ply need to decide what kinds of content you want to include on your website in order to convey and accomplish 
those goals.
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Defining your audience

Just like the purpose of your site can influence what your content is, the audience of your website can influence it 
as well.  Audience is simply the group of people that you are gearing your site towards, and just like the web site 
purposes, web site audiences can vary drastically from site to site.  Once you decide who your primary audience 
will be, you need to start considering what impact this will have on your content.  For example, the list below 
shows some factors to take into consideration. If you don’t know who will be looking at your site, or if you expect 
a diverse audience, it is best to plan for the lowest common denominator.

Education level?  (high school, undergraduate, Masters, Ph.D.s)
Computer expertise? 
Computer access?  
Web Browser choice?
Internet connection speed? 

•
•
•
•
•

Content format

Last but not least, when you’re deciding on what content to put on your site, it is also important to consider in 
what format or formats you want to make that content available.  For example, if you want to have your course 
syllabus on your site, do you want to type it out as an actual web page, or do you want to upload it as a Microsoft 
Word document or a PDF?  There are advantages to both methods and it’s up to you to decide which one will 
work best for your particular situation and for the particular considerations that you’ve decided need to be made 
for your site.

brainstorming site content

Use the table below to brainstorm about content you want to include on your website and the format that 
you want to use for each.

Content Format
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Ensuring func tionalit y

Once you have decided upon content, it is time to decide the structure in which the content will be presented.  
This means deciding what information will be on what page and how users will navigate your site.  A good way 
to do this is to create a flowchart.  Below is an example of a flowchart for a simple site.

The flowchart represents the organization of your website.  The top element (HOME) represents the page that 
people will begin on when they enter your site.  From that point, the website is divided into subcategories (light 
gray) and subpages (white).  These portions of the site are accessed through links, represented by the solid and 
dotted lines.

brainstorm site structure

Using the diagram above as an example, begin to create a flowchart for your own site.  
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Designing your site

There’s an old saying, “You never get a second chance to make a first impression.”  The same rule is true in web 
design.  The visual look and feel of a site can give an immediate impression to the viewer about the quality of the 
site.  In other words, just because you want to be aware of content and functionality doesn’t mean that your site 
can’t look nice too.  One of the simplest ways to begin thinking about your design is to create some quick sketch-
es, or storyboards, to get your ideas down on paper.  These sketches can be very simple and are only intended to 
be an initial conception of what your site as a whole could look like.  Below are a couple of examples of story-
boards:

Other design considerations

While the design of your site can go in any direction you want to take it, there are some practices and design 
principles that you want to be aware of.  Below is a list of some things you will want to pay attention to while 
designing a site.

SFSU has its own web policies for pages that are hosted on its servers.  You can view these policies at 
http://www.sfsu.edu/~puboff/webcommittee/policy/webpolicy.htm 
Don’t duplicate material that is already on the web unless it is absolutely necessary, just link to the 
original (for example, the SFSU bulletin)
Make sure that each page has a title.  This is what will show up on your browser’s title bar when your 
page is open.  It is also the text that will be used for the bookmark when someone bookmarks your 
page.
Compress images for your site with a program like Adobe Photoshop to decrease their file size.
Try to stick to a palette of five colors or less when designing your site.  
Try to stick to three or less variations of font type in your pages and make sure that it is big enough to 
be read easily.  
Chunk your information.  Breaking up long sections of information into smaller sections or separate 
pages will reduce the strain on the user.  However, if the user needs to print the information out, it is 
better to leave it all on one page.

•

•

•

•
•
•

•
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Introduc tion to Accessibilit y

Accessibility is the push to make websites to users of all kinds, including those who may be operating under 
different circumstances than the rest of us.  These circumstances may include blindness or vision impairment, 
deafness, inability to use a keyboard or mouse, or the use of a text-only web browser.  In 1998, Congress passed 
the Section 508 guidelines, mandating that all government agencies meet certain standards for web accessibility 
(among other things).  Therefore, by law, all official SF State webpages must meet, at bare minimum, the stan-
dards put forth in Section 508 (http://www.section508.gov).  

For more information on the Accessibility Standards and Guidelines at San Francisco State University, please 
consult the Accessible Technology Initiative website at http://www.sfsu.edu/access.  The site also contains many 
useful resources and best practices for how to ensure that your site meets the Accessibility checkpoints.

If you are interested in learning more about accessibility or about making your site accessible beyond the level of 
Section 508, consult the following sites:

Worlwide Web Consortium (W3C) - http://www.w3.org
W3C Web Accessibility Initiative - http://www.w3.org/WAI
Web Accessibility in Mind (WebAIM) - http://www.webaim.org

•
•
•

A word on Copyright

As an instructor, you must model proper copyright procedures for your students.  Copyright can apply not only 
to cited text that you reference on your website, but also to other elements of the site.  For example, using an 
image taken by someone else on your site can meander into the realm of copyright infringement pretty quickly. 
There are legal services on the SF State Campus that can help you in this respect.  You can also research the issue 
on your own.  In particular, Stanford University has a very thorough website regarding fair use that can be found 
at:  http://fairuse.stanford.edu.

Creative Commons

Creative Commons is a revolutionary website that allows you to publish your work online and custom tailor a 
copyright to tell people exactly what they can and cannot do with your work and to what extent they must credit 
you for the original creation.  For example, you can allow people to do nothing but cite your research work.  
Then turn right around and allow people to edit and build upon (commercially or non-commercially) another 
project of yours.  It’s completely customizable on a work by work basis and is becoming and increasingly preva-
lent means of securing copyright for online materials.
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A Quick Note on HTML

HTML stands for HyperText Markup Language.  HTML is the basic coding language in which web pages are 
written.  This code is then interpreted by your web browser (Firefox for example) and rendered as a webpage.  
While it is not necessary to understand HTML when using Dreamweaver, having a basic understanding of it can 
make things much easier.  If you decide you want to spend more time doing web design, it would be beneficial 
to start learning HTML code.  A good way to do this is to work in split view mode in Dreamweaver which will 
show both the source code and the more familiar and user-friendly design view.

So What Exac tly is Dreamweaver?

Once you finish your site, you still need to make it available to the public.  To do this, you need to move all of 
your files to a server where everyone else can access it.  This process is called publishing and usually requires a 
piece of software called and FTP (File Transfer Protocol) Client.  As we will see in the final part of this workshop, 
Dreamweaver has a built-in FTP Client.  This means that Dreamweaver is also a web publishing tool that can up-
load all of your webpages, images, files, etc. to your remote server so that the whole world can see your website.  
Again, we will discuss this in greater detail a bit later on.

HTML editor

Dreamweaver is an HTML editor, meaning it is a program that can edit HTML source code.  More importantly 
though, Dreamweaver is what is called a WYSIWYG editor (What You See Is What You Get).  This means that 
as you make changes on screen (in a fashion very similar to Microsoft Word) Dreamweaver creates and edits 
the HTML source code for you behind the scenes.  This makes it incredibly easy to create and modify web pages 
without an understanding of HTML. 

File Manager

Another feature that makes Dreamweaver such a powerful tool is its ability to manage your entire website, not 
just create and edit individual pages.  Once you have defined your site within Dreamweaver (which we will be 
doing later in this section), Dreamweaver will keep track of all the pages, images and files within that site.  Any-
time one of those files is moved, renamed or altered in any way, Dreamweaver updates all other files in the site to 
reflect that change.  This can save you a great deal of time and work in managing your website.  Please Note:  In 
order for Dreamweaver to recognize that changes have been made, you must make those changes from within 
Dreamweaver.  We will talk more about this later.

Web Publishing Tool
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Configuring Dreamweaver Preferences

The first time you use Dreamweaver on a computer, you will want to double-check the preferences for the pro-
gram to make sure that certain things are properly set up to make your website building process as simple and 
intuitive as possible.  Note that, unless you are using a computer which may have been modified by other users, 
you should only have to set the preferences the 
first time you use the program.

To set Dreamweaver preferences:

Select Edit > Preferences from the 
dropdown menus.
You will be shown a dialog box similar 
to the one shown below.  To navigate 
this dialog box, select a category from 
the list on the left.  When a category is 
selected, the right side of the box will 
change to show the available prefer-
ences that can be set for the selected 
category. This same type of interface is 
reused often in Dreamweaver.
Navigate the dialog box and make sure 
the preferences in the following table 
are set:

Category Preferences

General “Update Links When Moving Files” set to Prompt.

Accessibility Under “Shot Attributes When Inserting” make sure all elements 
are checked (Form Objects, Frames, Media, Images, Tables).

Invisible Elements Make sure Named Anchors and Line Breaks are checked.

1.

2.

3.
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The Dreamweaver Interface

Drop-down menus are a standard part of virtually every computer program.  Dreamweaver is no exception.  The 
drop-down menus in Dreamweaver include many of the standard options (creating new files, saving, opening 
files, copying, pasting, etc.).  One of the nicest things about the drop-down menus in Dreamweaver though is 
that everything you can do in Dreamweaver, can be found in the drop-down menus, making them a great place 
to check if you can’t find what you’re looking for elsewhere. 

Drop-down menus

Insert bar

The Insert bar in Dreamweaver is a collection of various tools and functions that have been grouped into various 
categories (Common, Layout, Text, Tables, etc.).  These various groups are made up of buttons that can be used 
to quickly add items to your web page without having to use the drop-down menus.  If you don’t see the Insert 
bar on your screen, you can open it by selecting Window > Insert from the drop-down menus.
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Document bar

While the Document bar allows you to do several things with respect to your document, it’s most important 
functions are to let you switch development views and to preview your page in an actual web browser.  

Clicking on one of the three buttons on the left of the bar (Code, Design, Split) will switch whether you 
are developing in HTML code, in the WYSIWYG (graphical editing) mode, or in a split screen with 
the top half displaying the page’s HTML code and the bottom half displaying the graphical editor. 
To preview your page in a browser, simply click on the image of the earth in the document bar and 
choose the browser you want to use.

If you don’t see the Document bar, select View > Toolbars > Document.

•

•

Properties panel

The Properties panel is probably the most important panel you can have open in Dreamweaver.  This is where 
you will make all your changes regarding elements of your web page, including font color, font size, link prop-
erties, image properties, table sizes and on and on.  The properties panel is context-sensitive, meaning that the 
contents of this panel will change depending on what you have selected in the document window.  If you don’t 
see this panel you can display it by selectinge Window > Properties from the menu bar.

Site panel

The Site panel can be used to manage your files in Dreamweaver.  The Site panel also displays all of the files 
that currently exist on your site and allows you to switch back and forth between your local and remote site (or 
expand the panel to view both side by side.  Last but not least, the site panel allows you to transfer files between 
your local computer and the remote server using Dreamweaver’s built-in FTP client.  If you do not see the Site 
panel on your screen, you can open it by selecting Window > Files from the drop-down menus.

Defining your Loc al Site

Before you can begin to utilize Dreamweaver’s site and file manage-
ment functions, you need to tell it where to find all your files.  And 
before you can tell it where to find all of your files, you need to put 
them all in one place.  However, for these functions to work prop-
erly, you need to first tell Dreamweaver where all of your files exist 
on your computer.  This process is called defining a local site (we’ll 
define the remote site later).

defining the local site

Remember, you’ll need to de-
fine your site for every com-
puter you use (i.e. home, office, 
etc).  You only need to define it 
once for each computer though.
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creating the root folder and organizing your files

Create a new folder to act as the root folder for your local site.  It doesn’t matter where you put 
this folder or what you call it as long as it is easy to find.
Create additional folders within the root folder as you see fit.  In general, you will want to create 
an images folder as well as possibly creating folders for different sections or types of content (e.g. 
a folder for each course you teach, a folder for documents).
Find any files you have that you want to include in your website and move (or copy) them into 
their appropriate places in the root folder.  For example, if you have a picture of your dog that you 
want to put on your website, you would move it into the ‘images’ folder that you created inside 
the public_html folder.

1.

2.

3.

Once you have created your root folder, you can define your local site in Dreamweaver so that it knows where to 
find all of your website files.

Creating your root folder
Before you get started defining the local site, you’ll want to make sure that all of the files you want to use for your 
site (images, PDFs, etc) are all located inside one main folder.  This main or root folder can have other folders in-
side it.  However, make sure that you don’t have any of your website files outside the root folder, as this can cause 
the files not to be uploaded later on and will result in broken links on your live website.

Defining the site

defining the local site

Select Site > Manage Sites from the dropdown menus.
In the dialog box, click on the New button and select “Site.”
Make sure the Advanced tab is selected in the ensuing window and select “Local Info” under 
Category.
In the Site Name box, type in a name for your site.
Click on the folder icon to the right of the Local Root Folder field and browse to select your root 
folder.
Click OK.
Click Done.

1.
2.
3.

4.
5.

6.
7.
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Creating a New Page in Dreamweaver

Now that we’ve got Dreamweaver’s preferences set up and our local site defined, we can start with the process 
of actually creating our webpage.  As with any other program, the simplest way to create a new document is to 
select File > New from the drop-down 
menus.  Upon doing that, you’ll be 
greeted by a dialog box like the one 
shown to the right.

To create a new document

Make sure the General tab 
is selected at the top of the 
box.
Under Category on the left 
side, select “Basic Page”;
On the right side, select 
“HTML”.
Select “Create”.

1.

2.

3.

4.

Setting page properties

Once you have created a new file and saved it, you can begin to set some of the page’s properties.  You can think 
of these properties as the page defaults.  They will determine, for example, what color your font is if you don’t 
specify otherwise.  

To alter your page proper ties

Select Modify > Page Properties from the drop-
down menus.
In the ensuing dialog box (see right), make 
changes to set up the default properties for the 
page, such as the default font, font size, font 
color, background color, etc.  Set the options to 
your personal preferences and taking into con-
sideration any specific restrictions that might be 
imposed by audience or functionality.
When you are done, click OK.
If you want to keep these settings for future pages, click Apply.
Click “OK”

1.

2.

3.
4.
5.
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Saving your file

saving conventions for the web

There’s an old mantra that comes up just about any time you work with digital files: “Save early ... Save 
often.”  In that same spirit, it’s never a bad idea, once you get your page preferences set, to go ahead and 
save your page.  Before you do though, there’s a couple of basic rules that are good practices to follow when 
naming files that will be used on the web.

Keep your filenames rather short (8-10 characters). 
Use all lowercase letters.
No spaces (use – or _ instead)
No special characters (&^%$#@!().,?/)
Make sure you use the proper file extension (.html, .jpg, .gif, .pdf, .doc, etc.) – It is worth noting 
that there is virtually no difference between .html and .htm.  Just make sure that whichever you 
choose, you stick with it throughout your site.

1.
2.
3.
4.
5.

Beginning to Build your Site

creating your first page

Create a new HTML document.
Set the Page Preferences for your document to define the default font, font size, background 
color, etc.  Note that you will need to define the page properties anytime you create a new page.
Also set a Title for your page.  You can set the title for your page using the text box in the docu-
ment bar.
Save the document as “index”.  (Note: if you don’t supply a file extension, Dreamweaver will auto-
matically use .htm).

1.
2.

3.

4.

Now that you’ve got all your page preferences set, it’s time to start building your site up.  To do that, we need 
to start learning how to use the various tools in Dreamweaver to add elements to our page.  The easiest place 
to start would be to learn how to add text and some of the simpler things.  However, thinking back to the early 
parts of the handout, we want to be aware of our three fundamental pillars of web design: content, function, and 
design.  To that end, before we start adding text and other forms of content, the first thing we want to do is build 
up the structure of our site.  For that, we’re going to need to know how to create and work with tables.  Let’s get 
to it.
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Creating layout tables

Tables are a very versatile element in web pages.  The reason is that tables have two distinct purposes in HTML.  
The first method of using a table is for organizing tabular data just as you would when using a table in Microsoft 
Word for example.  The second method is to use tables to create a page layout and help to position certain ele-
ments on screen.  While we will deal with both of these methods (and will explore a few important differences 
between the two), we’re going to start with the second method and creating layout tables.

Tables

Tables serve a very important function in web design.  While 
the basic use of a table still applies (that is, the presentation 
of tabular data), tables are also often used for layout.  Lay-
out can be defined simply as the position of elements on 
the screen.  Using tables for layout purposes allows you to 
create webpage designs with multiple columns and rows and 
maximize your usage of space within the browser window.  
For example, one of the most widely utilized layouts for web 
pages is one with a top banner, a left navigation, and an area 
for the actual content of the website.  The SFSU homepage, 
while somewhat more complicated, uses this design as its 
basic framework.  Look at the pictures to the right to see the 
SFSU home page and a diagram of the basic table structure 
at work in it. 

Generally, one table is enough to create your desired layout.  
However, some pages use tables inside of tables to further 
manipulate the layout of their pages.  This is called “nest-
ing” tables.  Again, the SFSU homepage will serve as a good 
example.  Look at the third picture to the right to see how 
the tables are nesting.  

While nested tables are not inherently bad, they should be 
avoided whenever possible as they increase a page’s down-
load time and can cause some accessibility problems.
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Data tables

A data table is a table that has been used to show the relationship between various pieces of information.  This 
is what is generally thought of when speaking of a table.  A good example of a data table would be a table that 
displays the contact information for a person.  Each cell in the table would hold a piece of information about that 
person.

Accessibility features of tables

One of the tricky parts of using tables is making them 
accessible.  To further complicate the matter, making data 
tables accessible and making layout tables accessible do 
not use the same process.  To make data tables accessible, 
you must include table headers (row / column identifiers 
that associate their respective data) and a table summary.  
Luckily, you will be prompted for both of these features 
every time you create a table in Dreamweaver (see right).

Conversely, to make a layout table accessible, you should 
never include headers or summaries.  This is because the 
headers and summaries are read out by a screenreader to 
try to make the data associations in the table more clear 
to blind users.  Adding headers and summaries to a layout table will only confuse blind users by attempting to 
describe a data relation that does not truly exist.  Just remember, data tables should always include accessibility 
information, layout tables never should.

cellpadding and cellspacing

Two very important and often confused table properties are cellpadding and cellspacing.  Put simply, cell-
padding is the space between the cell border and the content within the cell.  Cellspacing is the distance or 
gap between adjacent cells.  The picture below may help to illustrate the point better.
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create a layout table

In your “index” page, create a layout table with a width of 760px to begin building your site.  
Merge cells and add nested tables as necessary in order to mimic the design you sketched out in 
your storyboard.

create a data table

Create a new file and save it as “contact.htm”
Create a data table with your contact information, including your phone number, email address, 
and office number (don’t forget that since this is a data table, you need to include headers and a 
summary -- HINT: headers add to your total row and column count).

1.

1.
2.

Editing tables
Once you have created a table, it may be necessary at some point to change the table.  You can change individual 
settings about the table and its individual cells by selecting the desired table / cell and changing the properties 
(such as alignment, font, background color, etc) in the Properties Panel.  Aside from these basic changes, you 
can also change the structure of the table.  Below are some common ways to edit a table.

Merge cells

Click and drag across the cells you want to merge to 
select them.  
Select Modify > Table > Merge Cells from the drop-
down menus.

Adding Rows or Columns

Click within a table cell to select it.
Select Modify > Table > Insert Rows or Columns 
from the drop-down menus.
Select the number of rows / columns to insert and 
whether to insert them above or below the current 
cursor position.

Changing ver tical alignment of a cell

Click within the desired cell to select it
Find the pull-down menu in the Properties panel 
labeled Vert and change it to “Top.”

1.

2.

1.
2.

3.

1.
2.

One of the trickier parts of working 
with tables is making sure that you 
have the right part selected.  After all, 
the Properties panel will only show 
you properties for what you currenty 
have selected.  

To select a cell

Click within the cell.  

To select a table

Place your cursor in one of the table’s 
cells and select Modify > Table > 
Select Table from the drop-down 
menus.
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Adding Images

Inserting images into a webpage using Dreamweaver is actually a very simple process.  However, before we get 
started, take one last glance at your Files panel in Dreamweaver and look for the image you want to insert.  If you 
can’t find the image anywhere in the Files panel, it means that you haven’t moved the image into your site folder 
yet.  Remember, all of the files you want to use on your website (images incuded) need to be  inside your local 
root folder.

Once you have your images copied into your root folder, you can insert the image with the following steps:
Select Insert > Image from the drop-down menus.
In the dialog box, browse to the image you want to insert.  Select the image and click Choose.
Dreamweaver will prompt you for some alternate text for the image.  Supply your alternate text (see the 
Tips and Tricks box below for information on alternate text).
Click OK.

1.
2.
3.

4.

alternate tex t

Supplying alternate text for non-text elements (such as images) provides an explanation of the element for 
blind users utilizing a screenreader.  However, to be effective, you need to make sure that you are providing 
good alternate text.   Here are a few guidelines to follow when creating alternate text:

If the image has text in it (such as a link button), use the same text for the alternate text.
Always try to describe the purpose of the image (not necessarily what it is an image of).  For 
example, a picture of the earth that is being used as a link to your home page would benefit more 
from an alternate text of “Home” than it would from “Earth” since its purpose is to link the user 
to the Home page.

•
•

inser ting an image

Insert one of the banner images provided for you into the top row of your layout table to create a banner for 
your page.  Make sure you provide alternate text for the image.
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Creating Links

Links are what give webpages their interactivity and set them apart from other types of media.  There are several 
different types of links you can create in HTML (we will be using four). However, before we go jumping right 
into creating links to anything and everything on the web, it’s important to understand how exactly links work 
since it will help us to decide what type of links to make in different cirrcumstances.

Understanding paths

Most links include what is called a path.  The path is like a map that tells the computer where to find the specific 
file you are linking to.  Paths can be absolute or relative.  Much as their names imply, an absolute path tells you 
exactly where the file is whereas a relative path tells you where the file is relative to the location of the current file.  
To follow through with our map analogy, let’s assume you want to go to a certain store in downtown San Francis-
co and you need to know how to get there.  An absolute path would be the equivalent of having the precise street 
address of that particular building.  A relative path, on the other hand would begin with where you currently are 
and guide you to the store with a series of directives (‘right onto Market St., left onto Powell, etc.).  Both relative 
and absolute paths have their uses, as we will see below.

Four basic link types

Absolute links

These links are complete URL’s, including the protocol (the http:// 
part).  These are the types of links you must use if you want to link to a 
page that is not within your own site (for example http://www.google.
com).

Relative links

These are the links you use to link to files within your own site.  They 
use a relative path to tell the computer where the linked file is.

E-mail links

These links will open the email program associated with the user’s web 
browser and begin creating an email to the specified email address.

Named Anchors

These links work in pairs and mark a specific point in a document that 
you can jump to by clicking the link.  A fairly common example of this 
is the use of “Return to top” links.

email links

Be aware when you use email 
links that they can be found by 
programs called “email harvest-
ers” which will add your email 
address to spam lists.  While there 
are ways to confound harvesters, 
the only foolproof way to prevent 
them finding your email address 
is to not make it available in the 
first place.  However, since SFSU 
already lists your SFSU address, 
putting it up on your page won’t 
hurt anything.
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Creating an absolute link

Since absolute links are used to link to files that don’t exist on our site, Dreamweaver has no way of knowing 
where those files are.  Therefore, we have to specifically tell it exactly where the desired file is.  To do this, we sim-
ply need to know the URL of the file we want to link to (the easiest way to do this is to simply visit the webpage 
in a browser like Firefox and then copy the entire URL).  Once you know the URL for the page you want to link 
to, you can create your link by taking the following steps:

Select the text or image you want to use as a link by highlighting it (or cliicking on the image).
Find the Link field in the Properties Panel.
Type (or paste) the URL you want to link to in the field.  Note: in order for an absolute link to work, 
you need to provide the entire URL, including the protocol (the http:// part).

1.
2.
3.

create an absolute link

Using the method above, create a link to the SF State homepage (http://www.sfsu.edu)

Creating a relative link

Creating relative links in Dreamweaver is much simpler than creating absolute links because relative links are 
meant to link to files on your site and Dreamweaver already knows where all of those files are.  Therefore, you 
just need to tell Dreamweaver which file you want to link to and it will take care of the rest.  There are two very 
simple ways of creating relative links in Dreamweaver:

Method 1

Select the text or image you want to use as a link.
To the right of the Link field in the Properties Panel, click on the folder icon.
In the dialog box that appears, browse to find the file you want to link to.  Select it and click Choose.

Method 2

Select the text or image you want to use as a link.
Locate the icon to the right of the Link field in the Properties Panel that looks like a crosshair.
Make sure that the file you want to link to is visible in your Files Panel.
Click and drag the crosshair icon to the file you want to link to.  When your mouse is on top of the file, 
release your mouse button to create the link.

1.
2.
3.

1.
2.
3.
4.
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Creating an email link

creating a relative link

Using either of the methods listed above, create a link on your index.htm to the contact.htm page that we 
created earlier.

Creating an email link in Dreamweaver is also extremely easy:
Place your cursor where you want the email link (or highlight the text you want to use).
Select Insert > Email Link from the drop-down menus.
Supply the email address and the link text and click OK.

1.
2.
3.

creating an email link

Open the contact.htm file that we created earlier and make an email link to your email address.

Creating anchor links

Anchor links can be used on pages to move you up and down the page or to set positions on the page (such as a 
“Return to top” link).  Anchor links require two parts, the anchor and the link.  To create an anchor link:

Create the named anchor

Place your cursor where you want to the link to jump to.
Select Insert > Named Anchor from the drop-down menus.
Provide a name for the anchor and click OK.
Notice that a small anchor symbol will appear where your cursor was.

Create the link

Select the text or image you want to use for the link.
Using the crosshair method we used when creating a relative link, drag the crosshair to the small an-
chor symbol for the anchor that you want to link to.

1.
2.
3.
4.

1.
2.

creating an anchor link

Open the anchors.html file and create anchor links for the three different sections.
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Publishing your site

Now that you’ve created and edited your pages the way you want them, it’s time to publish your site to the web.  
Publishing for the web is similar to publishing a book.  Imagine you have been writing the great American novel 
on your computer and you just finished the last chapter.  The book is done!!  However, since the book exists only 
on your computer, there is no way for other people to read your masterpiece.  To give the public access to your 
novel, you have to get it published.  The exact same idea holds true for webpages.  Right now, you have finished 
your masterpiece (your website).  However, it only exists on the computer you’ve been using.  To make it avail-
able to the public, you need to upload all of your files to a web server.  And to make things even one step easier, 
Dreamweaver does this for you too!!

Local site vs. Remote site

The most crucial part of publishing your site lies in understanding the difference between a Local Site and a 
Remote Site.  The essential difference between these two is the place where they exist.  The Local Site consists of 
all your website files that exist on your computer (or whatever computer you were using to build your site).  In 
our case, the Local Site consists of the files that you have 
been creating and editing during this workshop.  The 
Remote Site, on the other hand, is made up of all the files 
that have been uploaded to the server where your web-
site is being hosted (the SF State servers for example).  It 
is important to note that these files are not always the 
same.  In other words, you can make all the changes you 
want to the local site and until you upload those changes 
to the server, no one else will be able to see them.  So 
how do you upload to the server?

Uploading and downloading

To upload and download files to and from your remote 
site, you will need to make use of an FTP program (FTP 
stands for File Transfer Protocol).  Think of your local 
and remote sites as opposite banks of a river.  In order 
for something to get across the river, there needs to be a bridge.  That’s what the FTP program does.  It creates a 
bridge between the two sites so that we can move files, images, etc. from one to the other.  While there are many 
FTP programs out there, Dreamweaver comes packaged with its own robust and very user-friendly FTP client, so 
we will use that.  Before we can use the FTP though, we need to tell Dreamweaver where our server is so that it 
can build that bridge.  We do this by defining our remote site in Dreamweaver.
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Defining your Remote site

Earlier in this workshop, we set up the definition for our local site in Dreamweaver.  If you don’t remember that 
process, take a minute to review it (page 16).  Setting up the local site in Dreamweaver allows Dreamweaver 
to keep track of all your files on your computer and manage them when file names / locations change.  Setting 
up the remote site allows Dreamweaver to perform similar functions for the files on the server.  To set up your 
remote site in Dreamweaver:

Select Sites > Edit Sites from the dropdown menu;
In the dialog box that pops up, select your site and click Edit;
In the new dialog box that pops up, select Remote info under the Category column;
Select FTP from the drop down list for Access;
You should now see something that looks like the picture on the previous page;
Fill out the various parts of the dialog box with your connection information.  If you are using your 
SFSU webspace, you can find your connection information in the table below;
Once you have filled in all of the information above, click Test;
You should receive a message saying that Dreamweaver successfully connected to the server.
Make sure the Save checkbox is checked and click OK;
Click Done to return to Dreamweaver.

1.
2.
3.
4.
5.
6.

7.
8.
9.
10.

Access

All FTP

FTP Host

Faculty online.sfsu.edu

Faculty, staff, students apollo.sfsu.edu    OR    orion.sfsu.edu

Departments www.sfsu.edu

Host Directory

Faculty, staff, students public_html

Departments my_www_files

Login information

Login Your SFSU email account (without the @sfsu.edu part)

Password Your SFSU email password

Remote Site Info for SFSU webspaces
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Viewing your remote site

Now that you have your remote site set up, you can view all the files on the remote site.  To view your remote 
files:

In the Files panel toolbar, click on the Expand / Collapse button ( ).
When the Files panel expands you will see that it is now divided into two parts.  The right half contains 
your local files.  The left half is where your remote files will appear.
To view your remote files, locate the Connect to Remote Host button ( ) on the toolbar and click it.
If you properly defined your Remote site in the previous section, your remote files will appear in the 
left side of the panel (though you may not see any files at this point, just a folder).

1.
2.

3.
4.

setting up your remote site

Use the table on the previous page as a guide and use your personal information to set up your remote site 
for your SF State webspace.

Uploading files manually

Now that you have your remote site defined, you can begin to publish your site to the web by uploading files to 
the server.  As with everything in Dreamweaver, there are several ways to go about doing this.  We will focus on 
two of the more popular methods – manual selection and Dreamweaver’s synchronization function.

Uploading to Your Site

Much as the name implies, this method requires you to hand pick the files to be uploaded.  This method has the 
advantage of letting you specify exactly what files you want to upload.  However, it also requires that you know 
which files you have and have not changed if you want to upload all of the most recent versions of your files.  To 
upload your files manually:

Make sure that the Files Panel is expanded and that you are 
connected to your remote site (as explained above).
On the right hand side of the panel (Local files), select the 
file(s) you want to upload to the server. 
Once you have all the files selected, click on the Upload / 
Put Files button ( )
Dreamweaver will upload the selected files to the server.

1.

2.

3.

4.

selecting files

If you need to upload several files, 
you can select multiple files by 
holding down the CTRL button 
when clicking on the files (Mac us-
ers hold down the command key).  
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Uploading with the Synchronize function

Dreamweaver’s Synchronization feature comes in very handy if you are updating your site from more than one 
computer or if you just aren’t sure which files have been changed and need to be uploaded.  By using Synchroni-
zation, Dreamweaver compares all the files on your local site with all the files on the remote site and determines 
which ones are more recent (i.e. which ones have been changed).  It will then upload only those files.  To syn-
chronize your files:

In the Files panel find the “Site” drop down menu and Select Site > Synchronize.  It is important to 
make sure you are using the drop down menu in the Files panel since the “Site” menu in the main drop 
down menus will not have a “Synchronize” option.
In the dialog box that pops up, choose what actions you want Dreamweaver to take set the Synchro-
nize option to “Entire Site.”
Also in the dialog box, tell set the action you want Dreamweaver to take.  To upload your changed files, 
choose “Put newer files to remote.”  To retrieve any newer files from the remote (thus ensureing that 
you are working with the latest copy of all of your files, choose “Get newer fles from remote.” 
Once you have set your options, click the 
“Preview” button.
Dreamweaver will take a few seconds to 
compare the files on the remote and local 
sites and then will pop up a dialog box (see 
image).  The dialog box will show all of the 
“newer” files found by Dreamweaver.  At 
this point, you can look through the files. If 
there is a file on the list that you don’t want 
to upload, uncheck the box beside it.  

1.

2.

3.

4.

5.

uploading files to your site

Using the manual selection method, select the root folder of your local site and upload it to your 
remote site. 
NOTE: Please only take this step if you don’t have anything on your remote site yet, as upload-
ing the whole site will overwrite any files with the same name that currently exist on the remote 
site.
Make a change to one of your files and run the synchronize command.  Dreamweaver should 
find the changed file (since it is a more recent version than the remote version) and allow you to 
upload it.

1.

2.
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Managing your site with Dreamweaver

Many people at SFSU have both a computer in their office and a computer at home.  Since these computers 
often contain different files, it is helpful to be able to update your webpage from either computer.  This is an easy 
process with Dreamweaver.  The most difficult part of maintaining your site from multiple computers is that you 
will have to define the Local Site and Remote Site on each computer (review the earlier sections of the handout if 
you need to).  However, all the settings for these processes will be the same regardless of which computer you are 
working on.  Once you have set up your site you can begin editing files.  But first, we need to get a copy of all the 
files onto the new computer

Expand the Files panel and make sure you are connected to the remote site.
Select the top folder in the Remote Files (public_html).
Click the Download / Get button (   ).
Dreamweaver will ask if you want to download the entire site.  Click “OK”
Dreamweaver will copy all of the files from your Remote Site to your computer. 

1.
2.
3.
4.
5.

Updating files from multiple computers

If you are editing your web pages from multiple computers (i.e. a work and home computer), site synchroniza-
tion becomes an invaluable tool.  Imagine you make some changes to one of your pages on your office computer 
and upload it to the server.  When you get home, you decide to make some more changes to the same page.  
When you open up the file, you see that the changes you made earlier in the office are no longer there.  This is 
because the file was edited on your office computer and uploaded to the server.  To get the edited file on your 
home computer, you need to download it from the server.  While this could easily be done using manual selec-
tion, what happens if there are multiple files that you changed at the office?  How do you make sure that you are 
using the most recent files and that you don’t accidentally overwrite a new file with an old one?  The answe is the 
synchronize function.

Before you create / edit any pages, use the Synchronization feature to get any newer files from the remote site.  
This will ensure that the computer you are working on has the most recent files before you begin editing.  Once 
you have all of the newer files, make any changes or 
additions you want to and save all your files.  Then 
use the Synchronize feature again to upload all of 
newer files to the remote.  Following this procedure 
will ensure that the server alwaays contains the 
most recent version of your file.
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